MFA Text Message Delivery Failures
Incident Report for Hope Trust
Postmortem

T-Mobile SMS messaging is intermittently failing to deliver to devices. Logs and monitoring report successful dispatch of SMS messages, so errors or indications of an issue were difficult to pinpoint.

This issue resolved itself, unfortunately. AWS was not reported to have intervened, T-Mobile made no mention of the issue.

Network bottleneck, unspecified deliverability issues.

Posted Feb 12, 2022 - 19:10 UTC

Resolved
This issue has been resolved. T-Mobile SMS message deliverability issues have been resolved. MFA functionality in the Hope Trust application has been restored.
Posted Feb 12, 2022 - 19:08 UTC
Update
We are in contact with AWS to resolve SMS deliverability issues. The T-Mobile network continues to report false delivery of SMS messages. You may have difficulty logging into your Hope Trust account if you have MFA enabled. For immediate assistance, please reach out to Hope Trust support through our live chat or directly at 1-833-467-3878.
Posted Feb 12, 2022 - 16:28 UTC
Update
We are continuing to monitor this issue.
Posted Feb 12, 2022 - 02:03 UTC
Monitoring
We have identified a bottleneck in the T-Mobile network. SMS messages are being halted for an unknown reason. We will continue to monitor this issue for resolution. For immediate assistance, please reach out to Hope Trust support through our live chat or directly at 1-833-467-3878.
Posted Feb 11, 2022 - 19:04 UTC
Identified
Amazon Web Services is currently having difficulty sending SMS messages to T-Mobile customers. Text messages are not being received by customers on the T-Mobile network. You may have difficulty logging into your Hope Trust account if you have MFA Authentication enabled.
Posted Feb 11, 2022 - 17:06 UTC
This incident affected: AWS Managed (User Services) and Users API.